Issue
Device language set to Spanish during initial device setup.
After installing channel and launching, cannot see content in channel.
Change device language to English and all channel content appears as expected.
Tried factory reset and still experiencing issue.
Environment
Direct Publisher
Fix
- Ensure that Spanish is selected as language under Manage My Channels > Preview and Update > Properties. If it is not selected, check the checkbox.
- Navigate to Manage my Channels > Preview and Update under appropriate channel > Categories. Select Spanish under Categories dropdown
- Add categories with appropriate tags to pull in desired content into the Spanish version of your channel.
- Click Save.
Cause
Language device settings should not affect what content is displayed in a channel. In this case, the channel was also enabled for Spanish in the Developer Dashboard Properties page, which means all additional localization settings needed to be updated accordingly (i.e. Categories, Channel Description).
Additional Resources
This solution will work for French or English as well, if you find that your channel is not displaying content correctly in those Languages.
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